Als cel gelijk is aan

Algemene formule

= ALS (A1="rood";waar;onwaar)

De functie uitgelegd

De ALS functie kun je gebruiken als je iets specifieks wilt doen als een cel aan een bepaalde waarde voldoet. Je kunt de ALS functie toepassen als je op een specifieke waarde wilt testen. Voor de waarde WAAR kun je een waarde bepalen en optioneel voor de waarde ONWAAR.

Als de waarde “rood” is, geef de waarde X

In het voorbeeld hieronder willen we simpel weg de rijen markeren of vlaggen waarvan de kleur waarde rood is. Met andere woorden, we controleren cellen in een bepaalde kolom en geven een vastgestelde waarde terug als de kleur rood is.

In cel D6 gebruiken we de volgende formule:

ALS(B6="red";"x";"")

In deze formule is de logische test:

B6 = "rood"

Het resultaat is WAAR als de waarde rood is en ONWAAR als de waarde anders is dan rood.

Aangezien we de cellen met de waarde rood willen markeren of vlaggen hoeven we alleen een waarde als de logische test WAAR is. We voegen een “x” toe aan kolom D als de waarde “rood” is. Als de kleur niet “rood” is (of leeg etc), voegen we een lege waarde toe (“”).

Het resultaat is een “x” als de kleur “rood” is en niets bij elke andere waarde.

Opmerking: Als we geen lege waarde (“”) invullen bij onwaar, de zal de waarde “ONWAAR” weergegeven worden.

Prijs verhogen als de kleur rood is

We kunnen deze formule nog wat moeilijker en uitgebreider maken. We gaan de prijs van de rode artikelen verhogen met 15%.

In dat geval kun je de volgende formule plaatsen in kolom E om de nieuwe prijs te berekenen.

=ALS(B6="rood";C6*1,15;C6)
ALS cel gelijk is aan met prijs verhoging

De logische test is hetzelfde als de vorige (B6=”rood”). Als het resultaat WAAR is vermenigvuldigen we de originele prijs met 1.15 (verhoging van 15%). Als het resultaat ONWAAR is, dan tonen we gewoon de originele prijs.