Als-cel-is-X-of-Y-en-Z

Algemene ALS formule

=ALS(EN(OF(A1= x;A1=y);B1=Z);"Ja";"Nee")

De ALS functie uitgelegd

Je kunt de logische functie combineren met OF en EN functie in de ALS functie.

Als product is kast of cd en het aantal is groter dan 10

In het voorbeeld filteren we regels waarvan het product kast of cd is en het aantal groter is dan 10.

De formule gebruikt in D5 is:

=ALS(EN(OF(B5="Kast";B5="Cd");C5>10);"x";"")

Hoe deze ALS formule werkt

In deze ALS formule is de logische test:

EN(OF(B5="Kast";B5="Cd");C5>10)

Let op dat we de ALS functie gebruiken waarbij de OF functie de eerste logische test is en C5>10 de tweede logische test.

Dit gedeelte van de code geeft alleen WAAR als het product in B5 een kast of een cd is en het aantal in C5 groter is dan 10.

De ALS functie geeft “x” als het resultaat WAAR is en “” (niets)  als het resultaat onwaar is.

Opmerking: als we de lege tekenreeks niet toevoegen als ONWAAR, geeft de formule ONWAAR als het product kast is.