De ALS functie gebruiken we om een logische-test uit voeren. Afhankelijk van de de uitkomst van deze test tonen we een waarde-als-waar of een waarde-als-onwaar.

De functie

ALS(logische-test; [waarde-als-waar]; [waarde-als-onwaar])

De ALS functie uitgelegd

De logische test bestaat uit een vergelijking van waarden. Voor het vergelijken van waarden gebruik je een operator. Operatoren zijn symbolen die specificeren welke berekening er uitgevoerd moet worden. Zo bestaat er de groter dan >, de kleiner dan <, is gelijk = etc.

Voor een geheel overzicht van operators zie Berekening operators in Excel. Als de vergelijking is afgerond weten we of de waarde waar is of niet waar. De waarde als waar moeten we verplicht invullen, de waarde als niet waar is optioneel.

In de praktijk

We gaan nu de functie nu in de praktijk brengen. Kopieer onderstaande tabel en plak deze in excel in cel A1 van een nieuw werkblad. Selecteer plakken speciaal en klik op plakken als tekst.

KentekenKm standOnderhoudOpmerking
Auto 11569330000
Auto 23448930000
Auto 35814560000
Auto 43120130000
Auto 5981530000

In dit schema houden we bij wanneer onze auto\’s naar de garage moeten voor een onderhoudsbeurt. Kolom 1 is voor de auto’s, kolom 2 voor de huidige km stand en in kolom 3 noteren we de volgende stand wanneer de auto voor een beurt moet. Ik kolom 4 gaan we de formule invoeren.

Nu willen we weten of de km stand (kolom 2) groter is dan de onderhoudstand (kolom 3). De logische-test is in dit geval B2 > C2, oftewel als B2 groter is dan C2 dan… Als de km stand groter is dan moet de waarde-als-waar zijn: Afspraak maken!. Is de km stand kleiner dan moet de waarde-als-onwaar zijn: Ok.

=ALS(B2>C2;"Afspraak maken!";"Ok")

Kopieer deze formule en selecteer cel D4. Zet je cursor in de formulebalk en rechtsklik voor de optie plakken of gebruik de sneltoetscombinatie CTRL + V. Druk vervolgens op enter. Om de werking te testen kun je nu de km stand in cel B2 aanpassen. Voer eens een getal in boven de 30000 en je zult zien dat de auto voor een beurt moet.

Selecteer nu cel D2 en kopieer deze naar cel D3 tot en met D6. Jouw bestand zal er ongeveer zoals hieronder uit moeten zien.

Voorbeeld ALS functie in excel

Door het aanpassen van de km standen is het nu makkelijk te zien welke auto er voor een beurt moet. Voor auto 2 en 4 zal een afspraak gemaakt moeten worden.