Verticaal zoeken

Samenvatting

Verticaal zoeken is een functie waarmee je data kunt ophalen uit een specifieke kolom in een tabel. De functie VERT.ZOEKEN ondersteunt exacte en soortgelijke overeenkomsten/ best mogelijke overeenkomst. Ook kun je het jokerteken gebruiken om een gedeeltelijke overeenkomst te vinden. VERT staat voor verticaal. De verticaal gezochte waarde moet in de eerste kolom van de tabel staan.


Doel

Het zoeken van een waarde op basis van een overeenkomst in de eerste kolom.

Syntaxis

VERT.ZOEKEN(zoekwaarde; tabelmatrix; kolomindex_getal; [benaderen])

Argumenten

Zoekwaarde – De gezochte waarde in de eerste kolom
Tabelmatrix – De tabel of bereik waarin de informatie is opgeslagen
kolomindex_getal – De kolom in de tabel waarvan we de waarde willen weten
Benaderen – (Optioneel) WAAR = niet geheel exacte overeenkomst. ONWAAR = Exacte overeenkomst.
WAAR kun je ook noteren als 1 en ONWAAR als 0.

Gebruik van VERT.ZOEKEN() functie

Met VERT.ZOEKEN haal je data op uit een tabel of een bereik welke verticaal is opgebouwd, waarbij elke rij een nieuw record is.

VERT.ZOEKEN records

Als je data hebt die horizontaal is opgebouwd kun je de functie HORIZ.ZOEKEN gebruiken.

Verticaal zoeken zoekt alleen naar rechts

VERT.ZOEKEN vereist dat de zoekwaarde in de meest linker kolom staat van de tabel of bereik. De kolom waar we de waarde van willen moet altijd rechts van de zoekwaarde staan in de tabel of bereik.

Verticaal zoeken rechts

VERT.ZOEKEN geeft data gebaseerd op kolomindex_getal

Stel voor dat elke kolom van de tabel is genummerd met meest links de eerste kolom. Geef vervolgens gewoon de kolom op in de kolomindex_getal welke je wilt weten.

Verticaal zoeken met meerdere kolommen
=VERT.ZOEKEN(E5;B11:E17;2;0) // Onderdeel
=VERT.ZOEKEN(E5;B11:E17;3;0) // Aantal
=VERT.ZOEKEN(E5;B11:E17;4;0) // Magazijn

VERT.ZOEKEN heeft twee methoden van benaderen, exact of niet geheel exacte overeenkomst.

Het vierde argument benaderen geeft aan hoe exact je zoekopdracht overeen moet komen, exact of niet geheel exact. Zet deze waarde op WAAR of 1 voor een soortgelijke retour waarde en op ONWAAR of 0 voor een exacte retour waarde. 

=VERT.ZOEKEN(ZOEKWAARDE;TABELMATRIX;kolomindex_getal) // standaard, niet exact
=VERT.ZOEKEN(ZOEKWAARDE;TABELMATRIX;kolomindex_getal,WAAR) // niet geheel exact
=VERT.ZOEKEN(ZOEKWAARDE;TABELMATRIX;kolomindex_getal,ONWAAR) // exacte waarde

Voorbeeld 1: Exact resultaat

In de meest gevallen wil je met verticaal zoeken de exacte uitkomst hebben.

VERT.ZOEKEN records

De formule in E6  zoekt verticaal op Artikelnummer met een exacte overeenkomst uit de kolom magazijn. De formule is:

=VERT.ZOEKEN(D6;B9:E15;4;ONWAAR) // ONWAAR = exact resultaat

Voorbeeld 2: Niet geheel exact resultaat

De benadering WAAR gebruik je indien je een zoekt naar het best mogelijke resultaat, niet een exact resultaat. Een voorbeeld hiervan is het vinden van de juiste commissie percentage op basis van de maandelijkse sales. In dat geval wil je de het beste resultaat voor de zoekwaarde. In het voorbeeld hieronder zal de formule in cel D5 het beste resultaat vinden in de kolom commissie percentage.

Verticaal zoeken met benadering WAAR
=VERT.ZOEKEN(C5;$G$4:$H$10;2;WAAR)

Opmerking: Om een juist resultaat te verkrijgen dient de tabel commissie bedragen en percentage wel  op volgorde gesorteerd te zijn.

Opmerkingen Verticaal Zoeken functie:

  • Benadering bepaalt of de zoekwaarde exact of niet overeen moet komen. Standaard is dat WAAR = niet exacte retour waarde
  • Geef benadering waarde ONWAAR voor een exact resultaat en WAAR voor het beste resultaat.
  • Als de benadering WAAR is (standaard waarde), wordt het beste resultaat gezocht die het dichts bij de zoekwaarde komt maar altijd minder is dan de zoekwaarde zelf.
  • Als de benadering niet wordt gespecificeerd is deze WAAR en kan er dus een zoekwaarde worden die niet geheel exact is. Als er een exacte waarde is zal deze worden geretourneerd.
  • Als de benadering WAAR (standaard waarde) is, zorg dan dat de data in de eerste kolom is gesorteerd van A-Z. VERT.ZOEKEN kan anders incorrecte of onverwachte data retourneren.
  • Als de benadering ONWAAR is (exact resultaat) maakt het niet uit of de eerste kolom uit de tabel gesorteerd is.
  • Als de benadering ONWAAR is (exact resultaat) en er zijn meerdere overeenkomsten zal de eerst gevonden waarde worden weergegeven.