Verticaal zoeken is een functie waarmee je data kunt ophalen uit een specifieke kolom in een tabel. Het nadeel is dat de functie is bedoeld om 1 resultaat weer te geven. Soms kan het zijn dat je meerdere overeenkomsten in de tabel hebt die je wilt tonen. In deze uitleg gaan we meerdere resultaten  in één lijst verwerken. 

Hoewel ik in de titel van dit bericht de term verticaal zoeken gebruik komt de hele functie niet voor in dit artikel. De functie verticaal zoeken is genoemd omdat het resultaat lijkt op verticaal zoeken. Hoe de functie verticaal zoeken exact werkt kun je lezen in het artikel Excel verticaal zoeken functie

Adresboek

We beginnen met een simpele adresboek tabel. We zien in de tabel enkele gelijkenissen zoals 3 Marieke’s en 2 keer de achternaam Peters. Als we nu VERT.ZOEKEN op Marieke krijgen we alleen de gegevens van rij 2. Er is immers een resultaat en dus is de functie voltooid. 

Excel-lent - Adresboek

Nu willen we juist een lijst krijgen van alle Marieke’s als ik zoek op de voornaam Marieke. In de volgende afbeelding van het tabblad “Zoeken” zien we het eindresultaat. We zoeken op voornaam Marieke en krijgen 3 records. Op de achternaam Peters vinden we 2 records.

Excel-lent - Adresboek zoeken op naam met meerdere resultaten

Werking van de zoek functie voor meerdere resultaten

Buiten de namen, telefoonnummers en email adressen zien we op het tabblad Zoeken nog een hulp kolom met getallen. De getallen corresponderen met de rij nummers van de persoon in het adresboek. Dit doen we middels de volgende formule:

=VERGELIJKEN($B$4;VERSCHUIVING(TELEFOONBOEK!$B$1;F3;0;1000;1);0)+F3

Zodra we het rijnummer weten kunnen we middels de volgende INDEX formules de overige gegevens uit deze ophalen:

=ALS(ISFOUT(INDEX(TELEFOONBOEK!C:C;$F4));"";INDEX(TELEFOONBOEK!C:C;$F4)) // Achternaam

=ALS(ISFOUT(INDEX(TELEFOONBOEK!E:E;$F4));"";INDEX(TELEFOONBOEK!E:E;$F4)) // Telefoonnnummer

=ALS(ISFOUT(INDEX(TELEFOONBOEK!D:D;$F4));"";INDEX(TELEFOONBOEK!D:D;$F4)) // Email adres

Op dezelfde wijze werkt ook de lijst van de achternamen. 

Download voorbeeld bestand

  Telefoonlijst-verticaal-zoeken-meerdere-waarden.xlsx – Bestandsgrootte 19,9 Kb