De SOM functie is een wiskundige berekening waarbij alle argumenten worden opgeteld.

De Functie

=SOM(getal1;[getal2];...)


De SOM functie uitgelegd

Met de functie SOM kunnen we cellen of een bereik bij elkaar optellen. Het is alleen mogelijk om numerieke waarden bij elkaar op te tellen. Een waarde als ‘5 zal eerst geconverteerd moeten worden naar een getal.

In de praktijk

We gaan nu de functie nu in de praktijk brengen. Kopieer onderstaande tabel met Ctrl + C en plak deze in excel in cel A1 van een nieuw werkblad. Selecteer plakken speciaal en klik op plakken als tekst.

Getallen
-4
12
28
‘8
WAAR
FormuleUitleg
=SOM(A2,A3)Deze formule telt de waarden op van cel A2 en A3. De uitkomst is in dit geval 8.
=SOM(A2:A4;15)Door het gebruik van de dubbele punt wordt hier de waarde opgeteld van cel A2 tot en met A4, om vervolgens de waarde achter de puntkomma erbij te rekenen. De uitkomst is in dit geval 51.
 =SOM(“6”;12;WAAR)Telt 6, 12 en 1 bij elkaar op. De “6” wordt omgezet in een getal en de waarde WAAR wordt omgezet in de waarde 1. Het eindresultaat is 19.
 =SOM(A5;A6; 2)Telt de waarden in cel A5 en A6 bij elkaar op, en telt vervolgens 2 op bij het totaal. Omdat niet-numerieke waarden in verwijzingen niet worden omgezet (de waarde in cel A5 (‘8) en de waarde in cel A6 (WAAR) worden beide als tekst beschouwd), worden de waarden in deze cellen genegeerd. Het resultaat is 2.

Als je een foutwaarde #Naam? krijgt, dan is er een fout gemaakt in het typen van de formule. Als sommige getallen niet worden opgeteld controleer dan of het bereik of de verwijzing numeriek is. Een logisch waarde zoals WAAR of tekst wordt genegeerd.

Meer over de SOM functei lees je hier: SOM() functie in Excel uitgelegd